NCTDTMFRECOGNIZER2Lib

NCTAudioStudio2 ActiveX DLLs
NCTDTMFRecognizer2 ActiveX DLL

Version 2.2

NCTDTMFRecognizer2 ActiveX DLL is intended for DTMF (Dual Tone Multi Frequency) recognizing.

NCTDTMFRecognizer2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTDTMFRecognizer2 documentation.
NCTDTMFRecognizer2 was developed by NCT company http://www.nctsoft.com


DTMFRecognizer2 properties

DTMFRecognizer2 properties

Property | Type | Default | Description
ArrayChannels | ChannelsConstants |  | Read-only property that returns the number of channels of the audio array. Mono data uses one channel and stereo data uses two channels.
ArrayFrequency | FrequencyConstants |  | Read-only property that returns a frequency of the audio array.
Quality | Long |  | Gets or sets the quality of recognizing.
RecognitionThreshold | Long |  | Gets or sets the value which determines sensibility of the recognizing algorithm.

Send Feedback on the NCTDTMFRecognizer2 documentation.
NCTDTMFRecognizer2 was developed by NCT Company Ltd. http://www.nctsoft.com


ArrayChannels property (DTMFRecognizer2)

ArrayChannels property (DTMFRecognizer2 object)

Read-only property that returns the number of channels of the audio array. Mono data uses one channel and stereo data uses two channels.

Property type

A ChannelsConstants value.

Syntax

object.ArrayChannels [= value]

The ArrayChannels property syntax has these parts:

Part | Type | Description
object | DTMFRecognizer2 | An expression evaluating to an object.
value | ChannelsConstants | Number of channels.

Remarks:

Set by SetFormatArray method.

Example:

' VB sample where Recognizer is an DTMFRecognizer2 object.
Dim nChannels As ChannelsConstants
nChannels = Recognizer.ArrayChannels

See Also:

ArrayFrequency

Applies to: DTMFRecognizer2


ArrayFrequency property (DTMFRecognizer2)

ArrayFrequency property (DTMFRecognizer2 object)

Read-only property that returns a frequency of the audio array.

Property type

A FrequencyConstants value.

Syntax

object.ArrayFrequency [= value]

The ArrayFrequency property syntax has these parts:

Part | Type | Description
object | DTMFRecognizer2 | An expression evaluating to an object.
value | FrequencyConstants | Frequency is in hertz.

Remarks:

Set by SetFormatArray method.

Example:

' VB sample where Recognizer is an DTMFRecognizer2 object.
Dim Frequency As FrequencyConstants
Frequency = Recognizer.ArrayFrequency

See Also:

ArrayChannels

Applies to: DTMFRecognizer2


Quality property (DTMFRecognizer2)

Quality property (DTMFRecognizer2 object)

Gets or sets the quality of recognizing.

Property type

A Long value.

Syntax

object.Quality [= value]

The Quality property syntax has these parts:

Part | Type | Description
object | DTMFRecognizer2 | An expression evaluating to an object.
value | Long | Varies from 1 (the worst quality) to 4 (the best quality).

Remarks:

The audio data is recognized by blocks (FFT window size). This method determines the stripe width of recognizing superposition.

For example if Quality is equal to 1 recognizing algorithms is not superimpose:

if Quality is equal to 2 recognizing algorithms is superimpose in the half of block:

See Also:

RecognitionThreshold

Applies to: DTMFRecognizer2


RecognitionThreshold property (DTMFRecognizer2)

RecognitionThreshold property (DTMFRecognizer2 object)

Gets or sets the value which determines sensibility of the recognizing algorithm.

Property type

A Long value.

Syntax

object.RecognitionThreshold [= value]

The RecognitionThreshold property syntax has these parts:

Part | Type | Description
object | DTMFRecognizer2 | An expression evaluating to an object.
value | Long | Varies from 1 to 90.

Example:

' VB sample where Recognize is an DTMFRecognizer2 object.
Recognize.RecognitionThreshold = 50
Recognize.SetFormatArray FQ_44_KHZ, STEREO
Recognize.StartRecognize
...
Recognize.StopRecognize

See Also:

Quality

Applies to: DTMFRecognizer2


DTMFRecognizer2 methods

DTMFRecognizer2 methods

Method | Description
Register | Enters a user name and a registration password to disable About window.
SendArray | Writes audio data array to the created output file.
SetFormatArray | Sets the format of audio data.
StartRecognize | Starts recognizing of the DTMF (Dual Tone Multi Frequency).
StopRecognize | Cancels recognizing of the DTMF (Dual Tone Multi Frequency).

Send Feedback on the NCTDTMFRecognizer2 documentation.
NCTDTMFRecognizer2 was developed by NCT Company Ltd. http://www.nctsoft.com


Register method

Register method (DTMFRecognizer2 object)

Enters a user name and a registration password to disable About window.

Syntax

object.Register(bstrUser As String, bstrPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | DTMFRecognizer2 | An expression evaluating to an object.
bstrUser | String | The user name. You get the registration user name after the registration.
bstrPassword | String | The password string. You get the registration password after the registration.

Example:

' VB sample where Recognize is an DTMFRecognizer2 object.
Recognize.Register "XXX", "XXX"

See Also:

Applies to: DTMFRecognizer2


SendArray method

SendArray method (DTMFRecognizer2 object)

Writes audio data array to the created output file.

Syntax

object.SendArray(InpArray As Integer())

The SendArray method syntax has these parts:

Part | Type | Description
object | DTMFRecognizer2 | An expression evaluating to an object.
InpArray | Integer() | Audio data array.

Example:

' VB sample where dtmfr is an DTMFRecognizer2 object and FileR is an AudioFile2 object from NCTAudioFile2 dll.
Dim Wav() As Integer
dtmfr.SetFormatArray FileR.ArrayFrequency, FileR.ArrayChannels
dtmfr.StartRecognize
Do While True
Wav() = FileR.ReadFile(BufferSize)
'reads from an audio file a piece of data of Buffer size to the Wav variable
If UBound(Wav) + 1 = 0 Then Exit Do
dtmfr.SendArray Wav()
'otherwise write currently read data block to the new created audio file
Loop
dtmfr.StopRecognize

See Also:

Applies to: DTMFRecognizer2


SetFormatArray method

SetFormatArray method (DTMFRecognizer2 object)

Sets the format of audio data.

Syntax

object.SetFormatArray(ArrayFrequency As FrequencyConstants, ArrayChannels As ChannelsConstants)

The SetFormatArray method syntax has these parts:

Part | Type | Description
object | DTMFRecognizer2 | An expression evaluating to an object.
ArrayFrequency | FrequencyConstants | Frequency of the audio file.
ArrayChannels | ChannelsConstants | Number of channels for the audio file.

Remarks:

Sets ArrayChannels and ArrayFrequency properties.

Example:

' VB sample where Recognize is an DTMFRecognizer2 object.
Recognize.SetFormatArray FQ_44_KHZ, STEREO

See Also:

Applies to: DTMFRecognizer2


StartRecognize method

StartRecognize method (DTMFRecognizer2 object)

Starts recognizing of the DTMF (Dual Tone Multi Frequency).

Syntax

object.StartRecognize()

The StartRecognize method syntax has these parts:

Part | Type | Description
object | DTMFRecognizer2 | An expression evaluating to an object.

Remarks:

The StopRecognize method cancels recognizing of the DTMF.

DTMF refers to the combination of two tones that represent a number on a telephone key pad. Each push-button has its own unique combination of tones.

Example:

' VB sample where Recognize is an DTMFRecognizer2 object.
Recognize.SetFormatArray FQ_44_KHZ, STEREO
Recognize.StartRecognize
...
Recognize.StopRecognize

See Also:

StopRecognize

Applies to: DTMFRecognizer2


StopRecognize method

StopRecognize method (DTMFRecognizer2 object)

Cancels recognizing of the DTMF (Dual Tone Multi Frequency).

Syntax

object.StopRecognize()

The StopRecognize method syntax has these parts:

Part | Type | Description
object | DTMFRecognizer2 | An expression evaluating to an object.

Remarks:

The StartRecognize method starts recognizing of the DTMF.

DTMF refers to the combination of two tones that represent a number on a telephone key pad. Each push-button has its own unique combination of tones.

Example:

' VB sample where Recognize is an DTMFRecognizer2 object.
Recognize.SetFormatArray FQ_44_KHZ, STEREO
Recognize.StartRecognize
...
Recognize.StopRecognize

See Also:

StartRecognize

Applies to: DTMFRecognizer2


DTMFRecognizer2 events

DTMFRecognizer2 events

Event | Description
Recognize | Occurs when the number or symbol is recognized.

Send Feedback on the NCTDTMFRecognizer2 documentation.
NCTDTMFRecognizer2 was developed by NCT Company Ltd. http://www.nctsoft.com


Recognize event

Recognize event (DTMFRecognizer2 object)

Occurs when the number or symbol is recognized.

Syntax

Sub object_Recognize(Simbol As Integer)

The Recognize event syntax has these named arguments:

Part | Type | Description
Simbol | Integer | Recognized number or symbol.

Example:

 ' VB sample where DTMFR is a DTMFRecognizer2 object
Private Sub DTMFR_Recognize (ByVal Symbol As Integer)
    List1.AddItem "Symbol = " & Symbol & " (" & dg(Symbol) & ")"
End Sub

See Also:

Applies to: DTMFRecognizer2


NCTDTMFRecognizer2 constants

NCTDTMFRecognizer2 constants

Constants | Description
ChannelsConstants | These are the constants for the following property and method: ArrayChannels property (DTMFRecognizer2), SetFormatArray method.
FrequencyConstants | These are the constants for the following property and method: ArrayFrequency property (DTMFRecognizer2), SetFormatArray method.

Send Feedback on the NCTDTMFRecognizer2 documentation.
NCTDTMFRecognizer2 was developed by NCT Company Ltd. http://www.nctsoft.com


ChannelsConstants enumeration

ChannelsConstants enumeration

These are the constants for the following property and method: ArrayChannels property (DTMFRecognizer2), SetFormatArray method.

Members

Part | Value | Description
MONO | 1 | Mono data uses one channel.
STEREO | 2 | Stereo data uses two channels.


FrequencyConstants enumeration

FrequencyConstants enumeration

These are the constants for the following property and method: ArrayFrequency property (DTMFRecognizer2), SetFormatArray method.

Members

Part | Value | Description
FQ_96_KHZ | 96000 | 96000 hertz.
FQ_88_KHZ | 88200 | 88200 hertz.
FQ_48_KHZ | 48000 | 48000 hertz.
FQ_44_KHZ | 44100 | 44100 hertz.
FQ_32_KHZ | 32000 | 32000 hertz.
FQ_24_KHZ | 24000 | 24000 hertz.
FQ_22_KHZ | 22050 | 22050 hertz.
FQ_16_KHZ | 16000 | 16000 hertz.
FQ_12_KHZ | 12000 | 12000 hertz.
FQ_11_KHZ | 11025 | 11025 hertz.
FQ_8_KHZ | 8000 | 8000 hertz.
FQ_6_KHZ | 6000 | 6000 hertz.


DTMFRecognizer2

DTMFRecognizer2 object

NCTDTMFRecognizer2 ActiveX DLL is intended for DTMF (Dual Tone Multi Frequency) recognizing.


NCTDTMFRECOGNIZER2Lib

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTDTMFRecognizer2 ActiveX DLL is intended for DTMF (Dual Tone Multi Frequency) recognizing.

NCTDTMFRecognizer2 is a part of the NCTAudioStudio2 package.